WPML Multilingual CMS WordPress Plugin

WPML Multilingual CMS WordPress Plugin v4.5.6

No permission to download
  • You MUST read the Babiato Rules before making your first post otherwise you may get permanent warning points or a permanent Ban.

  • You MUST read the Babiato Rules before making your first post otherwise you may get permanent warning points or a permanent Ban.

    Our resources on Babiato Forum are CLEAN and SAFE. So you can use them for development and testing purposes. If your are on Windows and have an antivirus that alerts you about a possible infection: Know it's a false positive because all scripts are double checked by our experts. We advise you to add Babiato to trusted sites/sources or disable your antivirus momentarily while downloading a resource. "Enjoy your presence on Babiato"

startop

Active member
Feb 18, 2019
667
111
43
Same problem here with WP 5.9
Plugin could not be activated because it triggered a fatal error.


Code:
You don't have permission to view the code content. Log in or register now.
 
Last edited:
  • Like
Reactions: deo
B

bsomar

Guest
I sent a message to WPML Support and that was their response :

"We are aware of this issue and apologize for the inconvenience. Our developers are already preparing another quick release to fix this. It should be going out this week. In the meantime, if you\'re experiencing this issue, it\'s best to downgrade WPML back to the 4.5.2 version and wait for us to release 4.5.4. Again, it should be out very soon. Thank you for your understanding!"
 
S

soiamilk

Guest

v4.5.3 doesn't work with Wordpress 5.9​

v4.5.2 need license key to active , not like other version can skip . i guess 4.5.9 is same​

 
B

bobsmith

Guest
@Kao X3

I will grab this and have a little play around with it and see if it works for me.

As you know I've been using 5.9 WordPress and have not had any issues with running themes, plugins and addons on it before they have been officially made compatible for the 5.9.

Like those listed in the post here provided by @AR90 😁

A good many of those plugins I have been using with 5.9 nightly build and release candidates before it was released public.

With v4.5.2 needing a licence key, that could be sorted if it is able to add it in the plugin.

However, with the latest version v4.5.3 crashing on activation, that could simply be as they have said and it is not compatible with 5.9 as of yet.

Or, without looking at all the error messages for it, it could just be a code error that they did not spot before releasing and it might not be connected to WP 5.9.

Will test it and come back as soon as I can with any results. 🤞👍
 
  • Like
  • Love
Reactions: jackes and Kao X3
B

bobsmith

Guest
@Kao X3 - Well I am not sure what everybody is moaning at here as i have got v4.5.3 working fine 😁😁

wpml1.png

I had just grabbed files from this thread, previous versions and the separate classes zip file.

All I did was this....
  1. Installed v4.4.10 and activated it, it asked for key so move on to newer version;
  2. Installed v4.5.1 and during setup it asked for key again;
  3. Looked in WPML tab and checked Support and made sure that all the necessary was setup correctly *****
  4. Double checked that my WP Settings were good enough for the needed requirements for this;
  5. Checked the two php files in separate zip against same php files in plugin and identical;
  6. So, went back to setup window and entered NulledbyMe as key;
  7. As stated in previous posts, it was a set amount of characters and then a green tick appeared;
  8. Key was accepted and I could move onto the next step of the setup;
  9. Did not proceed further with setup, instead moved on to newer version;
  10. Installed v4.5.2 and went back to setup, refreshed to update versions and setup still good and showing still the next step after key;
  11. Installed v4.5.3 and went back to setup, refreshed to update version and setup all fine again still.

So I have no worries with it working in WordPress v5.9 with the latest version of v4.5.3.....

wpml4.png

*****
Make sure you check your own Support settings as they need to all be green as per the requirements, otherwise you run the risk of it not working for you and running into errors.


As shown here, my local site was fine and all showing green, change yours if needed before you setup WPML....

wpml2.png

wpml3.png
 
Last edited:
B

bobsmith

Guest
@Kao X3

All I have done is to get it to work and show that there is no issues with it not working with WordPress v5.9 or producing fatal errors on activating v4.5.3 😁

I have not gone through and checked everything from the changelog.


Released on: January 25, 2022

Features
  • Add a new WPML language switcher to login and registration pages to replace the core language switcher for these pages introduced in WordPress 5.9.
  • Added support for translating Full Site Editing templates.

Bugfixes
  • Allow to sync post type archive menus.
  • Fixed an issue to ensure the get_adjacent_post function returns the correct links.
  • WPML installer page no longer shows Translation Management on the list of available plugins when WPML version 4.5 or newer is active.
  • Fixed an issue where the Language Switcher disappeared from the menu after changing the default language.
  • Renamed the “logs” directory to prevent unwanted deletion.
  • Fixed an issue that occured when using a different name for the “wp-content” dir.
  • Removed redundant AJAX calls when using the Classic Translation Editor.
  • Removed all fallbacks to the Classic Translation Editor when using Advanced Translation Editor.
  • Removed all source map files from the production package.
  • Fixed an issue where the Translation Review Bar was displayed behind the “Preview is not available” overlay.
  • Added a hint to the Translators page about the Translation Reviewer Directory.
  • Removed unused calls to synchronize Translators endpoints.
  • Removed Media Translation as a recommended plugin.

Compatibility
  • Removed wpautop when saving string translations for visual fields in Elementor.
  • Fixed a fatal error when Elemtentor’s widget is broken.
  • Disabled the language selector for WordPress widgets used with the Elementor builder.
  • Added support to translate graphic_image in Elementor’s “Call To Action” widget.
  • Added support for pop-ups inside hotspots in Elementor.
  • Fixed a warning message in Elementor Theme Builder.
  • Replaced _register_controls (deprecated) with register_controls in Elementor.
  • Added support for Elementor’s WooCommerce Purchase Summary Widget.
  • Fixed Divi’s display conditions when it uses categories.
  • Fixed an issue with WPBakery page builder where the raw HTML was being stripped from translations.
  • Added support for Avada’s “Off Canvas” translation.
  • Fixed an issue with the native Block Editor where an HTML attribute in blocks contains some HTML entities.
  • Fixed an issue with the native Block Editor with missing self-closing tags when the translation is being updated.
 
  • Like
Reactions: Babak

KaoVN

Active member
Null Master
Trusted Uploader
Oct 15, 2019
118
56
35
DeletedAccount
1.1.1.1
@Kao X3

All I have done is to get it to work and show that there is no issues with it not working with WordPress v5.9 or producing fatal errors on activating v4.5.3 😁

I have not gone through and checked everything from the changelog.


Released on: January 25, 2022

Features
  • Add a new WPML language switcher to login and registration pages to replace the core language switcher for these pages introduced in WordPress 5.9.
  • Added support for translating Full Site Editing templates.

Bugfixes
  • Allow to sync post type archive menus.
  • Fixed an issue to ensure the get_adjacent_post function returns the correct links.
  • WPML installer page no longer shows Translation Management on the list of available plugins when WPML version 4.5 or newer is active.
  • Fixed an issue where the Language Switcher disappeared from the menu after changing the default language.
  • Renamed the “logs” directory to prevent unwanted deletion.
  • Fixed an issue that occured when using a different name for the “wp-content” dir.
  • Removed redundant AJAX calls when using the Classic Translation Editor.
  • Removed all fallbacks to the Classic Translation Editor when using Advanced Translation Editor.
  • Removed all source map files from the production package.
  • Fixed an issue where the Translation Review Bar was displayed behind the “Preview is not available” overlay.
  • Added a hint to the Translators page about the Translation Reviewer Directory.
  • Removed unused calls to synchronize Translators endpoints.
  • Removed Media Translation as a recommended plugin.

Compatibility
  • Removed wpautop when saving string translations for visual fields in Elementor.
  • Fixed a fatal error when Elemtentor’s widget is broken.
  • Disabled the language selector for WordPress widgets used with the Elementor builder.
  • Added support to translate graphic_image in Elementor’s “Call To Action” widget.
  • Added support for pop-ups inside hotspots in Elementor.
  • Fixed a warning message in Elementor Theme Builder.
  • Replaced _register_controls (deprecated) with register_controls in Elementor.
  • Added support for Elementor’s WooCommerce Purchase Summary Widget.
  • Fixed Divi’s display conditions when it uses categories.
  • Fixed an issue with WPBakery page builder where the raw HTML was being stripped from translations.
  • Added support for Avada’s “Off Canvas” translation.
  • Fixed an issue with the native Block Editor where an HTML attribute in blocks contains some HTML entities.
  • Fixed an issue with the native Block Editor with missing self-closing tags when the translation is being updated.
:D
Me too
Don't see any errors here
Tested on Wordpress Core 5.8.3 + 5.9.0 + 5.9.1 + Nightly :D
All run on NGINX server
 
B

bobsmith

Guest
:D
Me too
Don't see any errors here
Tested on Wordpress Core 5.8.3 + 5.9.0 + 5.9.1 + Nightly :D
All run on NGINX server

Yes exactly, it all runs fine, for starters they need to double check their settings and setup as it should all be fine.
Both of us have it working fine so it can't be us doing something wrong 🤣
 
  • Like
  • Love
Reactions: Babak and Kao X3
S

soiamilk

Guest
i tried old ones .it works , new version they ask put key before process to next step . old version can skip it
 
B

bobsmith

Guest
Version 4.5.4 has been released on 27th January. Do you have the update? Thanks.
i tried old ones .it works , new version they ask put key before process to next step . old version can skip it

If somebody can get hold of it then it will be added here, just have to wait 😉

They all asked for key, that is why it was nulled so you could enter anything with a set amount of characters.

If you have just updated to this latest version of v4.5.4, then you will lose the changes and revert back to the clean untouched version.
 

Foxman

Member
Jan 21, 2020
46
11
8
bobsmith wrote: "They all asked for key, that is why it was nulled so you could enter anything with a set amount of characters."

Why this:

key.jpg
 
  • Like
Reactions: soiamilk
B

bobsmith

Guest
bobsmith wrote: "They all asked for key, that is why it was nulled so you could enter anything with a set amount of characters."

Why this:

key.jpg

Do what i did and go back through this thread and read old posts, you will easily find posts that contain the correct procedure and classes folders to be able to make it work.

Just like I have said in my procedure twice already as shown here again:

I had just grabbed files from this thread, previous versions and the separate classes zip file.

Checked the two php files in separate zip against same php files in plugin and identical;
So, went back to setup window and entered NulledbyMe as key;

As in above, I simply used 'NulledbyMe' which is ten (10) characters and the green tick appeared.

You have used more numbers than my ten characters for starters!
 
  • Like
Reactions: Babak

Babak

Well-known member
Staff member
Administrator
May 24, 2018
60,883
79,529
120
31
Babak updated WPML Multilingual CMS WordPress Plugin with a new update entry:

WPML Multilingual CMS v4.5.4

Download WPML Multilingual CMS v4.5.4 WordPress Plugin Nulled Free
WPML Multilingual CMS v4.5.4
Released on: January 27, 2022

Fixes​

  • Fixed a fatal error that occurred while updating the plugin if the site is using the WPML Blog License.
  • Fixed a fatal error that occurred after updating the plugin when the site is runinng on a filesystem that is not case sensitive (i.e. Windows).
  • Fixed a fatal error that occurred when using separate domains per...

Read the rest of this update entry...
 
  • Like
  • Love
Reactions: bobsmith and Foxman

Similar threads

Forum statistics

Threads
51,796
Messages
662,706
Members
133,785
Latest member
mawerick432